Technikai fórum

SCORM csomag nem működik

 
 
Kép
SCORM csomag nem működik
Kertész Róbert írta 2018. január 22., hétfő, 13:21 időpontban
 

Kedves Kollégák!

 

exe1.04 programmal egy kis csomagot hoztam (volna) létre.

A "SCORM_modszertaniutmutato_tarsinf_eger_fuzet_5" utasításai alapján jártam el, mégsem lett kézzelfogható eredmény.

A zip feltöltése után az oldalsávban látom az oldalak struktúráját, de minden oldalnál csak az villan be egy pillanatra, ha rákattintok, hogy "Tevékenység betöltése folyamatban, várjon…"

Egy régi, 2.1-es MOODLE biztosítaná a csomag lejátszását...

Segítségeteket előre is köszönöm!

Kép
Tárgy: SCORM csomag nem működik
Békefi Éva írta 2018. január 22., hétfő, 14:22 időpontban
 

Kedves Róbert!

Hasonló problémám volt nemrégen, én az alábbi megoldást találtam itt a fórumon:

Exe programból könyvtárba rendezett html-t exportáltam és egy scorm csomagot is, a scorm csomagban található imsmanifest.xml filet áthelyeztem a könyvtárba rendezett html-be, azt becsomagoltam.

A moodle feltöltéskor pedig a  scorm csomag feltöltéskor kivettem a navigálás megjelenítését és a kurzusszerkezet megjelenítését.

Így van egy scorm csomagnak kinéző html feltöltve. DE működő hierarchiával és navigálással.

Ahogyan utána olvastam az exe-ben létrehozott struktúra navigációja és a moodle navigációja bír összeveszni. 

Üdvözlettel:

Békefi Éva

Kép
Tárgy: SCORM csomag nem működik
Kertész Róbert írta 2018. január 23., kedd, 14:20 időpontban
 

Kedves Éva!

Nagyon szépen köszönöm a gyors választ! Sajnos nem segített - valamit elronthatok...
Már tegnap délután kipróbáltam, meg éjszaka, meg ma délelőtt, de bármit változtatok, sehogy sem lesz látható az eredmény.
(Jól értelmeztem, hogy CSAK az imsmanifest.xml-t kell átmásolni?)

Ha IMS-tartalomcsomag exportot választok, az működik, csak így a SCORM "lényege", a feedback veszik el, mert nem látom, hogy az adott témához tartozó tesztet hogy oldják meg. Persze tudom, hogy erre is van megoldás --> IMS, majd egy különálló teszt...

Még egyszer köszönöm!
Üdvözlettel:

Kertész Róbert

Kép
Tárgy: SCORM csomag nem működik
Papp Gyula írta 2018. január 23., kedd, 17:37 időpontban
 

A hibának számos oka lehet - akár a Moodle is :-)

De az 1.0.4-es eXe-t már nagyon nem érdemes használni. A spanyolok fejlesztik tovább és már 2.1.3-nál tartunk ha jól emlékszem.

Innen lehet letölteni: http://exelearning.net/?lang=en

Az is lehet, hogy a csomaggal van baj.

Ha át tudod/lehet küldeni - SCORM validáció szempontjából meg tudom nézni.

Kép
Tárgy: SCORM csomag nem működik
Kertész Róbert írta 2018. február 2., péntek, 14:54 időpontban
 

Köszönöm a reakciót, kedves Gyula!

Az előző héten erősen másra kellett koncentrálnom, így nem tudtam (és nem is akartam) válaszolni bejegyzésedre. Gondoltam, tényleg, milyen hülye vagyok, egy régi verzióval szórakozom, biztosan ez lehet a hiba. Tegnap kipróbáltam az általad ajánlott helyről letölthető újabb verziót - azzal sem megy, tehát valószínűleg a MOODLE lehet a hibás, ahogy írtad.

Nem nagyon vannak php meg egyéb ismereteim - van viszont egy rendszergazdánk, aki lehet, hogy tud segíteni. Milyen beállítással lehet gond?

Ha időd engedi, kérlek, válaszolj!
Előre is köszönöm!

(Illetve hogyan küldhetnék át Neked egy kisebb próba-állományt, amit megnéznél?)

Kép
Tárgy: SCORM csomag nem működik
Kertész Róbert írta 2018. február 2., péntek, 17:20 időpontban
 

A 2.1.3 eXe-t töltöttem le, azzal próbáltam új csomagokat létrehozni.

Valamilyen alap-hibát követhetek el, mert a csomagban (zip) benne vannak a képek is, de mégsem látszanak az IMS-csomagként exportált állományban sem! A beágyazott videók igen, de a képek nem. (A szerkesztő képernyőn úgy látszik, hogy teljesen rendben van.)

Kérek valami ötletet, ha tud valaki segíteni!

Előre is köszönöm!