Technikai fórum

Tárhely probléma

 
 
Kép
Tárhely probléma
Niethammer Zoltán írta 2017. október 11., szerda, 08:13 időpontban
 

Sziasztok!

Már a második tárhely szolgáltatóval küzdök, mivel a legújabb moodle nem települ fel. PHP problémák vannak, de én nem értem ezeket annyira. A szolgáltató meg azt mondja, hogy átalakítja a szerveren a PHP környezetet, de akkor a többi ügyfélnek lesz gondja. Ebben az esetben meg visszacsinálnak mindent. Nem garantálják a működést.

Szóval, tudnátok olyan tárhely szolgáltatót javasolni, ahol kapásból megy a moodle? Az iskola joomla honlapját is vinném. Kb. 10-15 G tárhely kellene.

Üdv:

Niethammer Zoltán

 

Kép
Tárgy: Tárhely probléma
okgyuri okgyuri írta 2017. október 11., szerda, 08:51 időpontban
 

Szia!

Én a tarhelypark.hu-n üzemeltetek Moodle-t. C-Panel-en keresztül installállható szkript-ből egy-két gombnyomással, biztosított az automatikus mentés, gond nélkül és gyorsan fut. (Bár a php beállítást módosítani kellett, de ez is megy C-Panele-en keresztül, segítek, ha kell) A comega7.hu tárhely Moodle-re van optimalizálva, az is jó (ingyenes volt még 1 éve a kipróbálása), de az jóval drágább, mint a Tárhelypark.

Gyuri

Kép
Tárgy: Tárhely probléma
Niethammer Zoltán írta 2017. október 11., szerda, 09:34 időpontban
 

Melyik verzió van telepítve?

Nekem egy Moodle 3.0.2+ (Build: 20160304) verziót kellene áthoznom a régi tárhelyről. 

Kép
Tárgy: Tárhely probléma
Bakos Csaba írta 2017. október 11., szerda, 09:25 időpontban
 

Szia!

Nekem itt van, én adom meg hogy melyik PHP verzió legyen és azon belül is mi legyen használva.

Ezek a lehetőségek,  fix a méret, nem dinamikus.

Több éve használom  náluk nem volt szolgáltatás kimaradás az ő hibájukból és normális az árképzésük.

És egyszerűen lehet telepíteni bármit ezzel a Softaculous CMS installálóval

 

A PHP verziók

 

Kép
Tárgy: Tárhely probléma
Niethammer Zoltán írta 2017. október 11., szerda, 09:28 időpontban
 

Érdekes amit írsz, mert éppen most kaptam tőlük egy levelet, hogy nem fog menni a legújabb moodle. Lehet, hogy régebbi verzióval megy?

Kép
Tárgy: Tárhely probléma
Bakos Csaba írta 2017. október 11., szerda, 09:54 időpontban
 

Melyik Moodle? A Moodle 3.3.2+ verzióhoz PHP 5.6.5 van írva és az lett beállítva azzal megy most is. A 3.4-nek van PHP 7, ha elérhető lesz be fog kerülni a választhatóak közé. A PHP-t ők is frissítik folyamatosan

Mivel folyamatosan frissítem azt a verziót használtam én is, működött annak egyébként PHP 5.4.4 verzió kellett. Át tudod vinni normálisan az egészet.

Az adattáblák átalakításról  meg csak ennyit írok:

Tool for converting tables

A command line tool is included in Moodle for converting tables to Barracuda.

To proceed with the conversion, run the command using the fix option:

$ php admin/cli/mysql_compressed_rows.php --fix

Szerintem megoldható.

 

Kép
Tárgy: Tárhely probléma
Niethammer Zoltán írta 2017. október 11., szerda, 09:51 időpontban
 

Köszönöm! Eddig ez tűnik a legjobbnak. Van még egy Moodle 1.9.19+ (Build: 20130513) rendszerem is, amiből 5-6 kurzust át kellene hozni a 3-as verzióba. Van erre valami egyszerűbb megoldás?

Kép
Tárgy: Tárhely probléma
Bakos Csaba írta 2017. október 11., szerda, 10:09 időpontban
 

Ha megfelelő méretűre fizetsz elő akkor egy aldomainre feltelepíted és azután lehet upgradelni.

A fórumon ezt találtam javaslatnak: you need to do a march from 1.9.19 >2.1.11>2.3.11>2.7>2.9 és valahogy a végén össze lehet hozni a kettőt.

Kép
Tárgy: Tárhely probléma
Niethammer Zoltán írta 2017. október 13., péntek, 20:47 időpontban
 

Szia!

Működik az új tárhelyen a moodle 3!

Egy kurzust át tudok telepíteni úgy, hogy letöltök egy biztonsági mentést a régi szerverről, és az új helyre feltöltve visszaállítom?

A mentés 36MB lett, és fel sem tudom tölteni, mert túl nagy. Lehet emelni a kvótát.

Próbáltam URL-ről letölteni, de az sem működött.

Hogyan lehetne néhány kurzust áthozni?

Üdv:

Zoli

 

Kép
Tárgy: Tárhely probléma
Bakos Csaba írta 2017. október 13., péntek, 22:04 időpontban
 

Szia!

Hívd fel őket, hogy 128 Mb-ra emeljék fel a feltöltési korlátot. post_max_size 128 és a upload_max_filesize 128 legyen

Ez a PHP alapértékén szokott lenni, 2 Mb és 20 Mb az kevés volt nálam is. 105 Mb volt a legnagyobb kurzus a 128 elég volt.

A Moodle biztonsági mentését kikapcsolhatod ők mentik arendszert és egyszerűen vissza lehet állítani Ezen a számon holnap is felveszik: +36205917115 vagy esetleg ezen +36203626984

Igen megoldható.

Kezdőoldal / Portáladminisztráció / Kurzusok / Kurzus visszaállítása és ott az állományt kiválasztva

A Moodle domain mentést meg ha jelzi a frissítést a Softaculous Mentés menüpontjával szoktam ezután megtenni, ha van egyedi sablonod azt előtte mentsd le és mielőtt a frissítés befejezéséhez belépnél a portálra töltsd vissza. Ha a beépített sablonok vannak használatban, akkor persze erre nincs szükség

 

Kép
Tárgy: Tárhely probléma
Niethammer Zoltán írta 2017. október 15., vasárnap, 09:20 időpontban
 

A Szerver-PHP info ezt mutatja, de a Biztonság - Portálszabványoknál max. 8M van. Mit kell még állítani? 

 

Kép
Tárgy: Tárhely probléma
Niethammer Zoltán írta 2017. október 15., vasárnap, 09:50 időpontban
 

MEGOLDVA!

Ez hiányzott a PHP.INI-ből:  post_max_size = 64M

 

Kép
Tárgy: Tárhely probléma
Bakos Csaba írta 2017. október 15., vasárnap, 10:16 időpontban
 

Szia!

Szerintem nyugodtan felemelheted ezeket az értékeket ennyire:

post_max_size = 128 és az upload_max_filesize = 128

A kurzusok könnyen meghaladhatják a 64-t

Kép
Tárgy: Tárhely probléma
Niethammer Zoltán írta 2017. október 11., szerda, 09:29 időpontban
 

A mostani szolgáltatóm ezt írta:

"Amugy nekem sem volt egyertelmu, a hiba alapjan a moodle forumon talaltam meg a megfelelo valaszt. A lenyege a dolognak az, hogy a mysql adatbazisban leteznek az un. storage enginek, vagyis az, hogy milyen modon tarolja el a mysql adatbazis az adatokat. Ebbol letezik a MyISAM es az InnoDB. Nalunk, mint altalaban mindenhol, van lehetoseg mindketto hasznalatara. Ez idaig rendben is van. A problema az, hogy ez a mysql eleg bonyolult es nem eleg, hogy tobb storage engine is letezik, de azon belul file tipusok is leteznek. Az InnoDB eseteben az Antelope es a Barracuda. Ez okoz problemat, ugyanis mi eddig az alapertelmezett Antelope formatot hasznaltuk, a moodle viszont a Barracuda formatot akarja hasznalni, a ket hibauzenetbol az egyik erre vonatkozott. Errol itt talalhato leiras:https://dev.mysql.com/doc/refman/5.6/en/innodb-file-format.html Az elso hibat ugyan gyorsan megoldottam, a masikhoz viszont egy globalis beallitas kellett, mert nem lehet csak 1-1 adatbazist Barracuda formatta alakitani, hanem az osszeset kellett a serveren. Erre irtam, hogy ez egyelore rendben van, kesobb viszont ez kompatibilitasi problemakhoz vezethet. Eppen ezert nem tudom garantalni, hogy ez igy is fog maradni."

 

Talán ez nektek mond valamit.